Home Forum Support Smoggie-PM will not work with Imuto Taurus X4L Battery Pack

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #28534


    160001D6 Smoggie-PM is working well but the location I want to use has no power so I have been using USB Power Packs. This has been working well but the power packs I had were old and only provided power for about 12 hours. I decided to buy a newer more powerful pack The Imuto Taurus X4L 20000mAh. https://www.imuto.com/index.php?route=product/product&path=18_41&product_id=79

    Battery Type: Li-Polymer Battery
    Capacity: 20000mAh/74Wh 3.7V
    Input: Micro USB 5V/2.1A (Max)
    Output: 2*USB 5V/2.4A (Max)

    iM-Power Technology: Detects your device intelligently and delivers the faster charge
    Dual USB output: 2*USB 5V/2.4A, 2 devices can charge at same time

    The X4L power pack works great for charging my phone but there is a problem when I use it to power the Smoggie. It provides power for about 45 secs and then the power pack powers down.
    I tried a different cable with same result. I was unable to try the cable that came with the power pack as it was physically too big to fit into the Smoggie. (It was just the plastic that was too big to fit. The actual connector looked as you would expect)
    As the power pack is able to power 2 devices at the same time I tried connecting a mobile phone to one output and the Smoggie to the other.
    This worked fine and the power pack charged the phone and provided power to the Smoggie.

    This isn’t a permanent solution though because once the power pack has charged the phone to 100% it powers down taking the Smoggie down with it!

    I haven’t contacted Imuto support yet.

    Not really expecting a fix but I thought I’d try the forum just in case it’s a cable issue or something that is configurable on the Smoggie.




    Hi Mike,

    Many, if not all battery packs do power off their outputs if the electric load on it is too light.
    You could connect a resistor parallel to the 5 volt output to create a load, but that seems dodgy 🙂



    Yes I saw that suggestion while searching online just now. Does seem a bit scary.
    Another solution I think looks like is going to work is to connect an external USB hard drive to the other connection. I’ve had it connected for 20 minutes so far and all is still powered up. The power pack has been saying it has 90% charge since I switched on. Smoggie fan is happily purring away as well. Not a real solution though as I don’t want to leave my hard drive outside as I want to use it inside! Would have to buy another hard drive. This is getting expensive.
    Thanks for the solution anyway

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.