Home Forum Support Fritz!Box router problems

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1603
    Radu
    Keymaster

    Some of those in the network, using the Fritzbox routers, indicated issues pinging the uRADMonitor units and for some, their units were unable to send data to the uRADMonitor server. Feel free to share details on this, if you have a Fritzbox router.

    #1604
    Markus Wichra
    Participant

    Hello Radu

    12000053

    I have two Fritzbox Routers 7170 with firmware 58.04.77 and 7330 with firmware 107.06.20

    No Problems

    #1605
    Joachim
    Participant

    Hello,

    I had the described problems with my FritzBox 6360 Cable after installation of uRADMonitor either.

    I tried several different LAN-ports, the monitor was visible in homenet and all required ports to the internet were open. Anyway, the uRADMonitor was not able to send packets.
    Suddenly it worked fine without any further action. I do not know the the reason for the problems up to now.

    I only can recommend to try several different ports and to restart your router after changing ports.

    Good luck.

    Joachim

    #1618
    Coos
    Participant

    Hello all,

    my FritzBox 7340 refused to talk with the uRadMonitor, it showed up with it’s local IP and that was all. The moment I connected an (very) old 10/100 mbit switch between the router and the uRadMonitor I could ping and see the local webpage.

    To make it work, I also disabled ‘Teredo filter’ and did a ‘port 80 forward enable’ for the uRadMonitor.
    The setup is not ideal because I have to reset the router, switch and uRadMonitor (in that sequence) on a regular basis.

    #1619
    Coos
    Participant

    Oh and by the way, I am a very new participant, my unitnumber is 12000059, got the thing working today just for the first time (after several tiresome hours of puzzling and trying).

    My location is in the SW of Netherlands 22km NW of the Belgian nuclair facility Doel (close to Antwerp)
    A.t.m. the unit is lying inside behind the window but I will mount it outside soon, at a height of about 1.5 meters so it is in the shadow of a balcony and will not receive much direct sun.

    #1634
    Coos
    Participant

    Hello everyone,

    since a few days I have the uRM (ID:12000059) connected to my network and since today also on the map.
    It gave me a hard time to make it talk with my FritzBox router.
    The solution seemed to place an 10/100 mbit 4-way switch inbetween the router and the uRM.
    The uRM uses TCP on port 80 which I forwarded in the router.

    Now I’m getting a hard time again as I try to include my Arduino with W5100 ethernetshield for my home-automation project in my network. It also uses port 80 and used to work like a charm in my network with the FritzBox. To make it work again I changed the port to 8080 in my sketch ( EthernetServer server(8080); ) and again the home-server works like a charm when I type : my_fixed_IP:8080/page_x . No problems with it.

    The problem now again is the uRM which seems to do not like another server on my router, it refuses to talk normally to the router and I have to reset the uRM every few minutes to get it talking again, after a request to my home-server the uRM hangs again and needs to be disconnected from the powersupply temporary to reconnect.
    So for the moment I disconnected the home-server while I try to find a solution.

    Am I doing something wrong or is it firmware or hardware related ?
    Any suggestions what I can try to do to make them both talk at the same time with the router ?

    Coos

    #1636
    Steve
    Participant

    I can’t really help and have no suggestions, but my setup works ok and is:

    I have my Raspberry Pi2 on port 80 (serving my web pages) and it is port 80 on my router.

    My uRadMonitor is accessible on port 8080 externally using port forwarding on my router to port uRadMonitor port80.

    I also have some other software on port 3837 port forwarded to port 3837 via my router too.

    They all work together just fine. When I hadn’t redirected incoming 8080 traffic to the uRadMonitor it was still transmitting data to the uRadMonitor server just fine even though my RPi had port 80 tied up and was serving pages.

    Normally only if someone wanted to view the uRadMonitor webpage or json data externally would they need to worry about port forwarding / router changes. Inernally the IP address should be just fine.

    e.g. depending local network settings, and to view data locally, it shouldn’t affect uploads to servers by each device.

    192.168.0.1 = router (port 80)
    192.168.0.3 = RPi (port 80)
    192.168.0.5 = Arduino (port 80)
    192.168.0.9 = uRadmonitor (port 80)

    Then using port forwarding rules in the router to access externally the addresses would be

    my_fixed_IP = Rpi
    my_fixed_IP:8080 = uRadMonitor
    my_fixed_IP:3837 = Inverter Data

    #1638
    Coos
    Participant

    Tnx Steve, that was a helpfull hint.
    I changed the router setup and connected the uRM with portforwarding rules from port 3837 to port 80.
    Now I can reach my Arduino server as before in a browser without adding a port number.
    From the outside world I can access the uRM with my_fixed_IP:3837 .

    Right now when I connect the Arduino-server to the network and access it with a browser, the uRM ‘crashes’.
    I can see on the local IP address 192.168.178.108 that the uRM went offline.
    On https://www.uradmonitor.com/?open=12000059 the ‘Last instant readings’ does not update anymore.
    5 to 10 minutes later the uRM reconnects to the network and I can connect again on 192.168.178.108 and a few minutes later the map will give a online sign again and the ‘Last instant readings’ updates again every minute.

    As long as the Arduino server page is opened in a browser it lets the uRM ‘crash’ again and the sequence repeats itself as long as there is arduino-server-activity. In a browser the webserver site updates itself every 15 seconds with XML for time_information and some settings.

    To me it looks like that the server traffic lets the uRM crash. But it may also be possible that my router goes nuts, i just do not know what and why this happens.

    Coos

    #1650
    Radu
    Keymaster

    Just as a note, the uRADMonitor units have a watchdog mechanism, that reboots the unit in case of no successful server communication in a 5minutes interval (that totals 5 attempts, as the units send out measurements every minute).

    #1652
    Coos
    Participant

    Radhoo, I had a lengthy telephone conversation with my I.S.P. after returning to the factory settings and thoroughly testing, the problems continued. The conclusion was that my FritzBox had severe problems. Probably only in a network with DHCP + fixed IP numbers together, what resulted in the repeatedly lost connections.
    In a few days I’ll get a another router/DSL-modem. I will report the results here asap.

    #1658
    Radu
    Keymaster

    Ok, looking forward to that. Thanks!

    #1672
    Coos
    Participant

    The new router, a Fritz.box 7360 solved all the connection issues with the uRM. It is now connected directly on one of the 10/100 Mbit router-ports and works perfectly together with more servers on my LAN.

    It is guessing about what was wrong with the old modem/router. Maybe problems with DHCP and fixed IP’s together or a problem with correctly synchronising with the 10 Mbit ENC28C60 of the uRM, or else IP4/IP6 issues.

    Whatever it was, everything is working now perfectly.

    #1683
    Radu
    Keymaster

    Hi Coos,

    Glad that this solved the problem. Good to know for the future in case anyone else happens to use Fritz!box routers. I merged the two topics together to have all information in one place.

    Radu

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.