Home Forum Support Can anyone help? A3 working intermittently at best, and only locally.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #28488
    evan
    Participant

    Just received my A3 WiFi HW:108 SW:77 last week. After many reboots, I was able to connect via USB and save the wireless login. The unit stayed live and reported to the dashboard for about 5 hours last Tuesday, and that was the last time it successfully connected to the dashboard. I’ve been trouble-shooting since then, and I haven’t heard back from Radu.

    After several reboots today, it would connect to my wifi network, and I could access it at its IP address. The page would auto-refresh with new values, and the device would then reboot every 120 seconds. Even while it was reporting those stats locally, it was showing as ‘offline’ on the web dashboard.

    Then one time after rebooting, it was no longer accessible at its local IP.

    I love the idea of this device, but right now it’s a several-hundred-dollar paperweight… my last message to Radu was 5 days ago with no reply.

    Can anyone help?

    #28490
    evan
    Participant

    After sending a return request via email, I received a reply stating that my other emails were never received.

    Dear Evan,

    I was surprised to ready your two emails below this morning . It seems that you tried to contact us for some problems, but for some reason your message never reached me.

    So before issueing a refund, would you like to get some assistance and have the problem fixed? What problems are you experiencing?

    If it’s related to connectivity, there’s a comprehensive guide on how to proceed with the A3, on the product’s documentation section online: https://www.uradmonitor.com/products/?sel=4#docs-4 , direct link: uRADMonitor with WIFI Configuration manual

    Waiting for your input.

    Thanks,
    Radu

    I suppose that’s possible, so I’m hoping Radu will be able to help resolve the issues. Since email seems unreliable, I’ll copy my reply here:

    Radu,

    I’m not sure how the previous emails didn’t arrive. They were replies to this very email thread, and show as sent successfully.

    I have read the documents several times and spent a few hours troubleshooting to no avail. The furthest I was able to get things was:

    • The device was accessible on the local wifi network at its IP address
    • Through the online dashboard, the device still shows as offline. No new data is being received.
    • Every 60-120 seconds of uptime, the device restarts itself. Sometimes it will come back up to the status described above, sometimes it will not be accessible at all, and will take several reboots before showing up on the local network again.

    So there seem to be two issues:

    1) The online dashboard is not connecting to the device.
    2) It frequently reboots, and behaves inconsistently when it does.

    As for online connection, since it has been accessible on the local network, it doesn’t seem to be a matter of its communication with the router – it’s clearly connecting successfully.

    I don’t even know where to begin to troubleshoot the frequent reboots. I’ve tried keeping it plugged into the wall directly, and tried plugging it into a power strip with backup power, and the symptoms are the same.

    If we can get it working reliably yet this week, I’m open to keeping it. Unfortunately I’m out of town again until Monday, so I won’t be able to do any further troubleshooting until then. I welcome any suggestions you have that could resolve the issues.

    Thanks

    #28492
    Radu
    Keymaster

    Not sure what happened, but thanks for taking the time to explain everything again. This is actually extremely helpful . Here is what I know from you:

    – device starts and connects to your WIFI router, following your initial SSID+WIFI KEY configuration
    – device presents it’s internal webpage , accessible via the LAN IP (this is what we call the router allocated IP in your local network)
    – the device reboots

    This information tells me the following:
    – device connectivity works
    – device sensors work (as you saw the data on the internal webpage)
    This is consistent with my expectations, as the device was tested prior to being shipped to you. Also since it is a digital device, partial failures are impossible. All device functionality is ok.

    The problem:
    – the device reboots

    The solution:
    The problem is caused by the device internal watchdog. This is a special kind of timer, displayed in the local web interface as “WDT” . You will see it gradually increase to a top limit where the reboot happens. The watchdog itself needs to be periodically reset (petting the dog), to prevent it from rebooting.
    It’s role is to protect the correct functionality of automated devices and trigger reboots when such hardware is in a deadlock or any other unrecoverable state, to limit human intervention and maintenance.

    The reason for why the watchdog is not reset and it eventually reaches the top limit and resets is related to the successful sending of the data. The data simply doesn’t reach the server . The server will not send an acknoledgement . The watchdog will see no successful response and will continue to increase until reboot when the entire things starts over. On the internal webpage you will see a “Stats” field, with the number of succesful data sends / total data sends. First will most likely be 0 in your case.

    Why this happens is related to the security settings in your network. You’ll need to connect to your router and rule out anything that might be blocking the A3 communication. A3 sends data by doing simple HTTP Posts, equivalent to a browser opening a webpage. The destination is port 80 on data.uradmonitor.com , make sure your router allows this.
    You will also need to do a separate test, where you create a Wifi hotspot on your phone, and have the A3 connected to that, to rule out any other problems created by your main WIFI Router.

    Again, your A3 has all its modules operational (sensors + wifi) , yet it keeps on rebooting and the data it sends is blocked.

    Waiting for your results!

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.