Home Forum Support A3 Ethernet can’t establish link with enterprise class network switch

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #28471
    Marius Paulauskas
    Participant

    Has anyone successfully connected A3 Ethernet variant to enterprise class network switch such as Cisco 2960S or 2960X? No matter what I do A3 only establishes link for split second and then reboots. I don’t see any frames coming out of it and no MAC address in switch CAM table.
    I tried everything possible like setting port into auto negotiation or tried all combinations of speed and dupplex, disabled all “smart” features like spanning tree and such but nothing works. Also tried power supply of higher voltage.
    A3 does work however if it is connected to home network type of switch which proofs unit itself is fine.

    #28474
    Wolferl
    Moderator

    Just guessing….maybe there is firewall enabled in that switch?
    Also try to enable all 10/100/1000M modes.

    #28475
    Marius Paulauskas
    Participant

    It has nothing to do with firewalls if link is not being negotiated.
    and what do you mean by “enable all 10/100/1000M modes”? It auto-negotiates speed/duplex but I also tried forcing manually – nothing worked.

    #28478
    Ken Jamrogowicz
    Participant

    I would like to explain my suggestion to add a length of cable between the A3 and the “enterprise class” switch. I have observed that some of the commercial switches that are designed to comfortably drive 1000M through 100m of cable are producing a rather powerful transmit signal. If you connect that to an Ethernet interface that is designed for “hobby” type application, the little transformers in the adapter can get saturated and make garbage out of the signal that the micro sees. The conclusion would be that this is not a valid network. It might barely work, if you force the connection to 10M because then you have some nanoseconds for the transformers to come out of saturation. But not for all data strings. Inserting a length of lossy cable between the switch and the A3 would ameliorate this particular problem (if it is the problem).

    Ken

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.